概述

在执行命令时发现无法查看selinux开放的端口列表。

[root@localhost ~]# semanage port -l
ERROR: policydb version 31 does not match my version range 15-30
ERROR: Unable to open policy //etc/selinux/targeted/policy/policy.31.
Traceback (most recent call last):
  File "/usr/sbin/semanage", line 32, in <module>
    import seobject
  File "/usr/lib/python2.7/site-packages/seobject/__init__.py", line 36, in <module>
    import sepolicy
  File "/usr/lib64/python2.7/site-packages/sepolicy/__init__.py", line 907, in <module>
    raise e
ValueError: 读取 //etc/selinux/targeted/policy/policy.31 策略文件失败

解决办法

升级或重新该命令安装包即可。

[root@localhost ~]# yum update -y policycoreutils-python
END

本文标题:查看selinux端口报错:policydb version 31 does not match my version range 15-30

本文作者:宇宙最帅的男人

本文链接:https://www.ym68.cc/linux/202130333.html

版权声明:转载或者引用本文内容请注明来源及原作者,本文著作权归作者 (宇宙最帅的男人) 所有。

除非另有说明,本作品采用知识共享署名-非商业性使用-相同方式共享 4.0 国际许可协议

最后修改:2021 年 11 月 30 日
如果觉得我的文章对你有用,请随意赞赏