概述

由于前同事升级Python版本至2.7.9导致原有的系统默认版本python异常,无法使用yum正常的功能。

[root@localhost ~]# yum update
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   cannot import name urandom

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.6.6 (r266:84292, Apr 11 2011, 15:50:32) 
[GCC 4.4.4 20100726 (Red Hat 4.4.4-13)]

If you cannot solve this problem yourself, please go to 
the yum faq at:
  http://yum.baseurl.org/wiki/Faq

处理办法

卸载原有python
[root@localhost ~]# rpm -e python-2.6.6-20.el6.x86_64 --nodeps
[root@localhost ~]# rpm -e python-devel-2.6.6-20.el6.x86_64 --nodeps
[root@localhost ~]# rpm -e python-libs-2.6.6-20.el6.x86_64 --nodeps
安装最新python
[root@localhost ~]# rpm -ivh http://s3-cn-bj.ufileos.com/filecloud/Mirrors/Centos/6/Packages/python-devel-2.6.6-66.el6_8.x86_64.rpm --nodeps
[root@localhost ~]# rpm -ivh http://s3-cn-bj.ufileos.com/filecloud/Mirrors/Centos/6/Packages/python-libs-2.6.6-66.el6_8.x86_64.rpm --nodeps
[root@localhost ~]# rpm -ivh http://s3-cn-bj.ufileos.com/filecloud/Mirrors/Centos/6/Packages/python-2.6.6-66.el6_8.x86_64.rpm --nodeps

分类: Linux